Environment

Preparing the Hi-Framework development environment

Minimum JDK version supported is 1.8. If you are stuck in 1.7, make sure you get the correct version installed before we proceed.

We will be using Maven 3 as our dependencies management tool, you could use any other or none if you know what you are doing.

We will be using a full blown Java EE container (CDI enabled). You can also proceed with a simple Web Container, as long as you manually add a CDI implementation and bootstrap it correctly.

Glassfish 4 would be a good choice. As long as you get a CDI 1.2 enabled container.

Github Repository